Increased error rate in our payments provider
Incident Report for Cypress
Resolved
Our payments vendor has resolved the issue. If you continue to encounter issues with our Billing & Usage page, please reach out to [email protected]
Posted 12 days ago. Oct 01, 2019 - 20:23 UTC
Investigating
We're seeing an increased error rate when interacting with our payments provider. Most operations are working as expected, but a few are timing out. You may experience issues on our Billing & Usage page while this issue persists. Please reach out to [email protected] if you need assistance in managing your billing during this time.
Posted 13 days ago. Oct 01, 2019 - 18:52 UTC
This incident affected: Billing.